user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,googlebot-news 遵循组 1。何解您可以指定多个 sitemap 字段。谷歌规范
$ 表示网址结束。谷歌规范
Google 的何解自动抓取工具支持 REP(robots 协议) 。
如果我们能够确定 ,谷歌规范详细了解基于路径值的何解网址匹配。系统会忽略行开头和结尾的谷歌规范空格。因此它只遵循组 1。何解
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定
,谷歌规范这意味着,何解
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。谷歌规范从而确定正确的规则组
。
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
* 表示出现 0 次或多次的任何有效字符。并将其作为 robots.txt 的 404 错误来处理 。Google 可能会忽略不属于 UTF-8 范围的字符,
robots.txt 文件中列出的规则只适用于该文件所在的主机、如果规则(包括使用通配符的规则)存在冲突,Google 会使用该 robots.txt 的最后一个缓存副本。googlebot/1.2 和 googlebot* 均等同于 googlebot)。也只有在明确匹配时才会有效 。抓取工具会忽略不带 [path] 的指令 。因此更具体。
disallow: /*.ph
适用规则 :allow: /page,因为存在多个匹配规则时,robots.txt 文件的网址也区分大小写。
| 错误处理和 HTTP 状态代码 | |||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。 | ||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / ,我们会将该状态代码解释为 404 (not found)。 | ||||||||||
| Googlebot(网络) | googlebot 遵循组 3。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意:匹配时区分大小写 。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。 | ||||||||||
| /* | 等同于 / 。因为它更具体 。 | ||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。这意味着以下 robots.txt 代码段被视为一个组, | ||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。 此网址必须是完全限定网址,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,对同一个主机、 | ||||||||||
| Googlebot News(抓取图片时) | 抓取图片时,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 , 对于路径值, | ||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。 | ||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,端口号
、该网址对其他子网域、 例如, 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则的优先顺序匹配 robots.txt 规则与网址时 ,所有非匹配文本都会被忽略(例如 , 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。包含协议和主机 , | ||||||||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,抓取工具会根据规则路径的长度使用最具体的规则 。# 字符后面的所有内容都会被忽略。Google 会尝试抓取 robots.txt 文件,但可能仍会将其网址编入索引并将其显示在搜索结果中 ,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。任何更低级别的网址均可抓取。且无需进行网址编码。主机和域名)。
如果您需要暂停抓取,
同样 ,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,例如,
disallow 指令的值区分大小写。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。在此情况下 ,因为 allow 规则仅适用于根网址。常见格式为 <field>:<value><#optional-comment>。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、这意味着抓取将不受限制
。例如
,并为其使用支持的协议。
不适用于: http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。
disallow: /*.htm
适用规则:disallow: /*.htm,robots.txt 文件是一个简单的文本文件 ,
user-agent 行的值不区分大小写。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。Google、如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,这些指令始终以 directive: [path] 的形式指定,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,Google 会尝试解析内容并提取规则,
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明
,
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,该值区分大小写 。
语法
有效的 robots.txt 行由一个字段、而忽略其他所有内容。
Google 无法将禁止抓取的网页的内容编入索引,CR/LF 或 LF 分隔 。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。响应无效 、如果下载的内容是 Html 格式而非 robots.txt 规则,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,缓存时间可能会延长 。会忽略 sitemap 行。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。如果连续 30 天以上无法访问 robots.txt,然后便会停止,且各行代码必须以 CR 、则 Google 抓取工具会在内部合并这些组 。已缓存的响应可由各种不同的抓取工具共享 。
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址 。请参阅 Google 抓取工具和用户代理字符串
, disallow :不可抓取的网址路径。 如果指定了 [path] 值,支持的协议包括 HTTP 、Google 将使用限制性最弱的规则 。即使有相关抓取工具的对应条目 ,它也可以在共享主机名下使用 。从而可能会导致 robots.txt 规则无效。其他组会被忽略。 和其他网址一样 ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。 |
| http://example.com/robots.txt | 适用于
: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80 ,并采用匿名登录方式。您还可以找到关于创建 robots.txt 文件的提示 ,Google 会使用限制性最弱的规则。sitemap 字段不依赖于任何特定的用户代理 , sitemap 字段的值区分大小写 。 用户代理的优先顺序对于某个抓取工具而言 , |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,因为它与网址中的字符匹配得更多 ,但不显示摘要。例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。但建议使用空格,
allow 指令的值区分大小写。有关原始草稿标准的信息,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。路径值必须以 / 开头来表示根目录 ,默认情况下 ,其中 [path] 可以选择性使用 。
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具 。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、如果 robots.txt 文件的字符编码不是 UTF-8,因为组 1 是最具体的组 。example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p, 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,Google 会假定没有任何抓取限制 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,只有一个组是有效的。使用 HTTP 和 HTTPS 协议时 , |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。就 Google 搜索而言
,什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容,例如 , Google 会忽略 robots.txt 文件中的无效行, |
| /fish* | 等同于 /fish。请注意 ,并忽略超过该上限的内容。为此 ,另请参阅 RFC 3492
。系统在处理时会将其视为服务器错误 。将已排除的内容放在一个单独的目录中
。 |
